I Keep Getting a 502/504 Error When Trying To Do Lab Requisitions, What Do I Do?

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Issue

The user is trying to create Lab Requisitions but they receive a spinning wheel that eventually times out and gives a 500/502 Error Page.

Environment

Kipu EMR, Labs Tab, Lab Test Requisitions, Roles: Super Admin, Records Admin, Doctor, and Nurse, Features: Lab Report Operator and Lab Requisition Operator

Resolution

If you are receiving a 502 or 504 error saying Bad Gateway Error or Gateway Time-out Error when trying to access the Lab Requisitions within your Kipu EMRs Labs tab check your Internet Connection Strength. This is likely an issue caused by a slow internet speed and your Facility would need to work directly with your Internet Provider to resolve this issue.

There are many free internet speed checkers online, check to see if your internet provider has one built into their website/app.

If your Internet Speed is not the issue, please contact Support for further help resolving this issue.

Cause

Slow internet speeds will commonly cause connection issues if they can not load quickly enough, this could happen from too many users limiting the bandwidth for each.

Additional Information

If your Internet Provider does not have an Internet Speed checker or you want to cross-check it with another one Google can provide many options, just be cautious that not all of the links may be reputable, you may want to check with your IT department if your facility has a preferred option or ask your Supervisor for a recommendation.

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